Foursquare latest checkins WordPress Plugin

This is a small WordPress plugin, that allows you to show your recent Foursquare checkins and the venue icon as a Widget in your blog’s sidebar.

The Plugin is now available through the official 4SQ App Gallery and the official WordPress Plugin repository.

Installation

Through WordPress

  • Go to “Plugins” in your admin backend.
  • Click “Add new”.
  • Search for “Foursquare Latest Checkins”.
  • Klick on “Install Now” on the first entry.

Manual

  • Download and extract the ZIP file below.
  • Copy the file “foursquare_latest_checkins.php” to your WordPress installation’s wp-content/plugins Folder.
  • Activate the Plugin in the WordPress Admin backend.
  • Add the Widget to your desired Sidebar location and fill in the necessary fields.

Screenshots

Download

Foursquare Latest Checkins WordPress Plugin

Download

 

 

 

Date: March 21st 2011

Version: 0.6

  • #1 written by megu
    about 3 years ago

    Looks like the plugin gives an error after 4SQ passed to HTTPS.

    It gives Warning: Invalid argument supplied for foreach() in /home/mguven/public_html/gebinet/ilovecesme.com/wp-content/plugins/foursquare-latest-checkins/foursquare_latest_checkins.php on line 49

    error

    Any update ahead?

  • #2 written by Florian Beer
    about 3 years ago

    The Plugin is still working fine here and there shouldn’t be any HTTPS related issues, because it uses the Foursquare API, which used HTTPS anyway (at least for non authenticated requests, but that would go too far into oAuth 2 mechanics).
    The error message means the plugin didn’t get any viable data from Foursquare, so better re-check your username and password in the settings.
    Could you maybe point me to the URL where you installed the plugin, so I can take a look at it?

  • #3 written by megu
    about 3 years ago

    Yeah my bad. I didn’t write my email as username =)

    thanks.

    you can take a look if you want to http://www.ilovecesme.com

    thanks for the plugin =)

  • #4 written by Luc
    about 2 years ago

    Hi,

    I just installed the plugin but it doesn’t work. The following message appears :

    Warning: Invalid argument supplied for foreach() in /home/ramenian/ramenos.net/new/wp-content/plugins/foursquare-latest-checkins/foursquare_latest_checkins.php on line 56

    Could you help me to fix it ?

  • #5 written by Florian Beer
    about 2 years ago

    Hello Luc,
    thanks for using my plugin!

    Are you sure you’ve got the latest version? http://tracking.42dev.eu/attachments/download/14/foursquare-latest-checkins-1.0.zip
    The error means there was no data returned by Foursquare, please re-check your Foursquare login credentials (Email & Password) in the Widget settings.

  • #6 written by Swizec
    about 2 years ago

    Hey,

    awesome plugin, but it looks like Foursquare has disabled the API you are using. Any plans for an upgrade?

    Cheers,
    ~Swizec

  • #7 written by Florian Beer
    about 2 years ago

    Unfortunately I don’t have the time to redo the plugin at this point.
    I’m very sorry, but as of now I can’t tell you when it’s gonna be available again.